# Error after Fuel Node upgrade

**URL:** <https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191>\
**Category:** General\
**Created:** [July 7, 2024, 6:21pm UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191 "2024-07-07T18:21:37Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![MonCumulo](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/moncumulo/32/2843_2.png) [@MonCumulo](https://forum.fuel.network/u/MonCumulo)\
**Post date:** [July 7, 2024, 6:21pm UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/1 "2024-07-07T18:21:37Z")

</div>

After the last update it seems that several users running the node have had the same problem:  
2024-07-07T18:19:47.702585Z ERROR new{name=cumulofuel-sepolia-testnet}:initialize\_loop{service=“P2P”}: fuel\_core\_p2p::peer\_report: 165: Dial failure: peer id `Some(PeerId("16Uiu2HAmDxoChB7AheKNvCVpD4PHJwuDGn8rifMBEHmEynGHvHrf"))` with error `Failed to negotiate transport protocol(s): [(/dns4/p2p-testnet.fuel.network/tcp/30333/p2p/16Uiu2HAmDxoChB7AheKNvCVpD4PHJwuDGn8rifMBEHmEynGHvHrf: : Connection refused (os error 111): Connection refused (os error 111): Connection refused (os error 111))]`

Installed fuel-core-keygen v0.30.0 for toolchain ‘latest-x86\_64-unknown-linux-gnu’

Installed:

- forc 0.61.2
- forc-wallet 0.8.1
- fuel-core 0.30.0
- fuel-core-keygen 0.30.0

Any thoughts?

---

<div class="post-metadata">

**Author:** ![naz3eh](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/naz3eh/32/2025_2.png) [@naz3eh](https://forum.fuel.network/u/naz3eh)\
**Post date:** [July 8, 2024, 6:51am UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/2 "2024-07-08T06:51:09Z")

</div>

Can you share which command you are running?

---

<div class="post-metadata">

**Author:** ![MonCumulo](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/moncumulo/32/2843_2.png) [@MonCumulo](https://forum.fuel.network/u/MonCumulo)\
**Post date:** [July 8, 2024, 3:01pm UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/3 "2024-07-08T15:01:04Z")

</div>

thanks for your answer, it’s the same command as before the update with which the node was running perfectly…

sudo tee /etc/systemd/system/fueld.service \> /dev/null \<\< EOF  
[Unit]  
Description=Fuel Node Beta-5  
After=network.target

[Service]  
User=$USER  
Type=simple  
ExecStart=$(which fuel-core run)   
–service-name cumulofuel-sepolia-testnet   
–keypair   
–relayer [https://eth-sepolia.g.alchemy.com/v2/](https://eth-sepolia.g.alchemy.com/v2/)   
–ip=0.0.0.0 --port=5000 --peering-port=40444   
–db-path $HOME/.fuel-sepolia-testnet   
–snapshot $HOME/.fuel-sepolia-testnet   
–utxo-validation --poa-instant false --enable-p2p   
–reserved-nodes /dns4/p2p-testnet.fuel.network/tcp/30333/p2p/16Uiu2HAmDxoChB7AheKNvCVpD4PHJwuDGn8rifMBEHmEynGHvHrf   
–sync-header-batch-size 100   
–enable-relayer   
–relayer-v2-listening-contracts=0x01855B78C1f8868DE70e84507ec735983bf262dA   
–relayer-da-deploy-height=5827607   
–relayer-log-page-size=500   
–sync-block-stream-buffer-size 30

Restart=on-failure  
LimitNOFILE=65535

[Install]  
WantedBy=multi-user.target  
EOF

---

<div class="post-metadata">

**Author:** ![naz3eh](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/naz3eh/32/2025_2.png) [@naz3eh](https://forum.fuel.network/u/naz3eh)\
**Post date:** [July 8, 2024, 6:34pm UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/4 "2024-07-08T18:34:28Z")

</div>

> [@MonCumulo](#):
>
> Description=Fuel Node Beta-5

It is trying to connect to the beta-5 network that has been deprecated now. With the new release of the testnet, the command has been changed, so I’d suggest you follow this [updated guide](https://docs.fuel.network/guides/running-a-node/running-a-local-node/#running-a-local-fuel-node)

---

<div class="post-metadata">

**Author:** ![MonCumulo](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/moncumulo/32/2843_2.png) [@MonCumulo](https://forum.fuel.network/u/MonCumulo)\
**Post date:** [July 9, 2024, 1:07pm UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/5 "2024-07-09T13:07:22Z")

</div>

Description is irrelevant to the functioning of the node as it is only the description of the service and it has worked with other versions of the node in Sepolia, in fact I have changed it some time ago and evidently I have followed the documentation … it still returns the same error and the same to several users running nodes with different configurations so I think the error does not come from there…

---

<div class="post-metadata">

**Author:** ![naz3eh](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/naz3eh/32/2025_2.png) [@naz3eh](https://forum.fuel.network/u/naz3eh)\
**Post date:** [July 10, 2024, 3:15pm UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/6 "2024-07-10T15:15:18Z")

</div>

hey @MonCumulo, please have a look at [this announcement](https://forum.fuel.network/t/release-of-the-new-version-of-fuel-core-0-31-0/6223), might be helpful to you. To use the latest version, you might need to update all the versions to the latest

---

<div class="post-metadata">

**Author:** ![MonCumulo](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/moncumulo/32/2843_2.png) [@MonCumulo](https://forum.fuel.network/u/MonCumulo)\
**Post date:** [July 10, 2024, 4:05pm UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/7 "2024-07-10T16:05:24Z")

</div>

I was just updating when I saw your message, everything ok, I updated and it is up and running and synchronised, thank you very much for the info!

---

<div class="post-metadata">

**Author:** ![naz3eh](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/naz3eh/32/2025_2.png) [@naz3eh](https://forum.fuel.network/u/naz3eh)\
**Post date:** [July 10, 2024, 5:40pm UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/8 "2024-07-10T17:40:45Z")

</div>

I am glad its working. lmk if you want more help

---

<div class="post-metadata">

**Author:** ![imostafa](https://avatars.discourse-cdn.com/v4/letter/i/77aa72/32.png) [@imostafa](https://forum.fuel.network/u/imostafa)\
**Post date:** [July 14, 2024, 8:05am UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/9 "2024-07-14T08:05:41Z")

</div>

i have same problem i updated to last version but i get this error

ERROR new{name=imostafa}:initialize\_loop{service=“P2P”}: fuel\_core\_p2p::peer\_report: 165: Dial failure: peer id `Some(PeerId("16Uiu2HAmDxoChB7AheKNvCVpD4PHJwuDGn8rifMBEHmEynGHvHrf"))` with error `Failed to negotiate transport protocol(s): [(/dns4/p2p-testnet.fuel.network/tcp/30333/p2p/16Uiu2HAmDxoChB7AheKNvCVpD4PHJwuDGn8rifMBEHmEynGHvHrf: : Handshake failed: Handshake failed: Handshake failed: Protocol negotiation failed.)]`

---

<div class="post-metadata">

**Author:** ![naz3eh](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/naz3eh/32/2025_2.png) [@naz3eh](https://forum.fuel.network/u/naz3eh)\
**Post date:** [July 15, 2024, 5:30am UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/10 "2024-07-15T05:30:56Z")

</div>

I have shared it with the team and will keep you posted

---

<div class="post-metadata">

**Author:** ![naz3eh](https://sea2.discourse-cdn.com/flex022/user_avatar/forum.fuel.network/naz3eh/32/2025_2.png) [@naz3eh](https://forum.fuel.network/u/naz3eh)\
**Post date:** [July 15, 2024, 1:45pm UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/11 "2024-07-15T13:45:25Z")

</div>

hey @imostafa, Can you please try [this solution](https://forum.fuel.network/t/release-of-the-new-version-of-fuel-core-0-31-0/6223/5)?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex022/uploads/fuel/original/2X/5/57d5a345cc15a64b636e0d56e042857f8a0e80b1.png) [@system](https://forum.fuel.network/u/system)\
**Post date:** [August 5, 2024, 9:46am UTC](https://forum.fuel.network/t/error-after-fuel-node-upgrade/6191/12 "2024-08-05T09:46:14Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
