Fuel latest testnet node: Error No such file or directory (os error 2)

Hi @mrenzidev ,

I’m heading to bed here, but I think this can’t find one of the configuration files or folders. Try looking at and ensuring the db-path , snapshot files/folders are in the right place.

I can take another look tomorrow morning.

hey @mrenzidev, just like Nick mentioned, its not getting the correct path for the config. I’d suggest you to follow the below steps once again to ensure its getting the correct path.

  1. Run git clone https://github.com/FuelLabs/chain-configuration.git to clone the chain config

  2. Run fuel-core run \ --service-name=fuel-sepolia-testnet-node \ --keypair {P2P_SECRET} \ --relayer https://sepolia.infura.io/v3/{INFURA_API_KEY}\ --ip=******* --port=4000 --peering-port=30333 \ --db-path=~/.fuel-sepolia-testnet \ --snapshot ./chain-configuration/ignition/ \ --utxo-validation --poa-instant false --enable-p2p \ --reserved-nodes /dns4/p2p-testnet.fuel.network/tcp/30333/p2p/16Uiu2HAmDxoChB7AheKNvCVpD4PHJwuDGn8rifMBEHmEynGHvHrf \ --sync-header-batch-size 100 \ --enable-relayer \ --relayer-v2-listening-contracts=0x01855B78C1f8868DE70e84507ec735983bf262dA \ --relayer-da-deploy-height=5827607 \ --relayer-log-page-size=500 \ --sync-block-stream-buffer-size 30 to start the node

I followed the above steps and it was working for me.
Lmk if you are still having issues :slight_smile:

1 Like

What wrong sir, “error: unexpected argument ‘–snapshot’ found”
my cmd:
fuel-core run
–service-name=fuel-sepolia-testnet-node
–keypair b325d6b1318986336f869f*************bee3e6a9
–relayer https://sepolia.infura.io/v3/ ******************
–ip=85.190.
.
--port=4000 --peering-port=30333
–db-path=~/.fuel-sepolia-testnet
–snapshot ./root/chain-configuration/ignition/
–utxo-validation --poa-instant false --enable-p2p
–reserved-nodes /dns4/p2p-testnet.fuel.network/tcp/30333/p2p/16Uiu2HAmDxoChB7AheKNvCVpD4PHJwuDGn8rifMBEHmEynGHvHrf
–sync-header-batch-size 100
–enable-relayer
–relayer-v2-listening-contracts=0x01855B78C1f8868DE70e84507ec735983bf262dA
–relayer-da-deploy-height=5827607
–relayer-log-page-size=500
–sync-block-stream-buffer-size 30

can you share the output from your terminal by running the command fuelup show?

I get a new error sir, Error: Could not open snapshot file: “./root/chain-configuration/ignition/metadata.json”

How to fix file metadata.json?

My fuelup show:
Default host: x86_64-unknown-linux-gnu
fuelup home: /root/.fuelup

installed toolchains

beta-5-x86_64-unknown-linux-gnu
latest-x86_64-unknown-linux-gnu (default)

active toolchain

latest-x86_64-unknown-linux-gnu (default)
forc : 0.60.0
- forc-client
- forc-deploy : 0.60.0
- forc-run : 0.60.0
- forc-crypto : 0.60.0
- forc-debug : 0.60.0
- forc-doc : 0.60.0
- forc-explore : 0.28.1
- forc-fmt : 0.60.0
- forc-lsp : 0.60.0
- forc-tx : 0.60.0
- forc-wallet : 0.7.1
fuel-core : 0.26.0
fuel-core-keygen : 0.26.0

fuels versions

forc : 0.62.0
forc-wallet : 0.62.0

the error shows that it is unable to detect the snapshot file. can you tell at what location you have cloned the chain-config repo?

1 Like

I clone here: GitHub - FuelLabs/chain-configuration

Please help, sir

Still getting the same error after redownloading from git.

root@vmi1614025:~# fuelup show
Default host: x86_64-unknown-linux-gnu
fuelup home: /root/.fuelup

installed toolchains

beta-5-x86_64-unknown-linux-gnu
latest-x86_64-unknown-linux-gnu
nightly-x86_64-unknown-linux-gnu (default)

active toolchain

nightly-x86_64-unknown-linux-gnu (default)
forc : 0.60.0+nightly.20240606.e1fcf98aa9
- forc-client
- forc-deploy : 0.60.0+nightly.20240606.e1fcf98aa9
- forc-run : 0.60.0+nightly.20240606.e1fcf98aa9
- forc-crypto : 0.60.0+nightly.20240606.e1fcf98aa9
- forc-debug : 0.60.0+nightly.20240606.e1fcf98aa9
- forc-doc : 0.60.0+nightly.20240606.e1fcf98aa9
- forc-explore : 0.28.1+nightly.20240606.4bb7392eed
- forc-fmt : 0.60.0+nightly.20240606.e1fcf98aa9
- forc-lsp : 0.60.0+nightly.20240606.e1fcf98aa9
- forc-tx : 0.60.0+nightly.20240606.e1fcf98aa9
- forc-wallet : 0.8.0+nightly.20240606.2c157b12d7
fuel-core : 0.27.0+nightly.20240606.bcce89e022
fuel-core-keygen : not found

This is the output.
Still same error.

Still getting the error, i posted the steps im doing to install the node. Cannot understand what im doing wrong…

Im doing everything from a screen session in /root folder, so tried for snapshot ./ or the absolute path… but same error.

Any help? Still looking to find a solution
Still cannot find a good guide.
1- Installed screen, and opened a new one
2- Im located in /root/
3- Installed rust
4- source “$HOME/.cargo/env”
5- curl … install.fuel.network | sh
6- fuel-core-keygen new --key-type peering
7- git clone FuelLabs/chain-configuration (so i currently sit in /root directory where i downloaded chain-configuration folder
8- fuel-core run …

Thanks

@Nazeeh21 can you please just take a look at my steps, to see if im doing something wrong?
Thx

hey @mrenzidev, I’d suggest you run the command to start the node in that same directory where you’ve cloned your repo. tbh that shouldn’t be an issue as long as you are passing the path correctly.

Just FYI these are the docs for running the testnet node but before running that make sure you are on the latest version by following the guide here