Error while I run: forc build

hello, I’ve been following the developer quickstart guide to build the counter contract.
forc build command gives me this error:

Error: failed to fetch ``. Check your connection or run in `--offline` mode

Caused by:
    authentication required but no callback set; class=Ssh (23); code=Auth (-16)

Following the error message, I tried this: forc build --offline and got this error:

Error: Unable to fetch pkg "std" from Url { scheme: "https", cannot_be_a_base: false, username: "", password: None, host: Some(Domain("")), port: None, path: "/fuellabs/sway", query: None, fragment: None } in offline mode


Are you trying to compile without internet connection?

1 Like

The Internet connection is fine. Looks like the issue happens due to git authentication issue mentioned here
Editing global github config worked for me.


did you find solutuion?

1 Like

See the temporary workaround mentioned in this issue comment:

The full solution is for us to handle git authentication properly in forc, which is one of our priorities before the next beta!


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.