State_config.json multiple wallets config fails for in memory node

I am trying to fund multiple wallets as per:
Running a Local Node | Fuel Docs,

we say here "You can edit the coins array inside state_config.json to modify the initial assets owned by a given address. "

so in state_config.json I have modified the coins array to have my wallet address

I start the node:

fuel-core run --db-type in-memory --debug --snapshot ./chain-configuration/local

however it fails to start with:

The initialization of the service failed.: Coin should not exist

If I remove the first element , the node starts and my wallet is funded


is it not possible to configure multiple wallets ?

fuelup show

installed toolchains
latest-x86_64-unknown-linux-gnu (default)

active toolchain
latest-x86_64-unknown-linux-gnu (default)
  forc : 0.60.0
    - forc-client
      - forc-deploy : 0.60.0
      - forc-run : 0.60.0
    - forc-crypto : 0.60.0
    - forc-debug : 0.60.0
    - forc-doc : 0.60.0
    - forc-explore : 0.28.1
    - forc-fmt : 0.60.0
    - forc-lsp : 0.60.0
    - forc-tx : 0.60.0
    - forc-wallet : 0.7.1
  fuel-core : 0.26.0
  fuel-core-keygen : 0.26.0

fuels versions
forc : 0.62.0
forc-wallet : 0.62.0

Thanks for reporting this @crypt0mate, I will look into and get back to you :slight_smile:

I tried it out locally and it worked for me Warp. I had even modified the state_config.json file and set the owner to my wallet address and it was working for me. This is my screenshot for the modified owner addresses

One thing that could be a problem is the owner address in line 8, can you change that to the B256 type address and try again?

I notice the owner on the first element of your coins array is not the same as the one found here: chain-configuration/local/state_config.json at master · FuelLabs/chain-configuration (

are we using the same file ? or did you change it also ?

no luck yet

fuel-core run --db-type in-memory --debug --snapshot ./chain-configuration/local

000000000000000000000 } }, consensus: ConsensusHeader { prev_root: 0000000000000000000000000000000000000000000000000000000000000000, height: 00000000, time: Tai64(4611686018427387914), generated: GeneratedConsensusFields { application_hash: 10da0ac8f480775bfc51f5e2f8066dd95f847c5f6b7f6c13b529a97f84f9a680 } }, metadata: Some(BlockHeaderMetadata { id: BlockId(b492ade362b06953001f0d79bca3f496ce0ebc63c0d34149b64e3feee748eb93) }) })
2024-06-27T11:34:18.196393Z  INFO new{name=fuel-core}:initialize_loop{service="FuelService"}: fuel_core::service::genesis::importer: 108: Running imports
thread 'tokio-runtime-worker' panicked at /project/crates/services/src/
**The initialization of the service failed.: Coin should not exist**
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace
2024-06-27T11:34:18.196675Z  INFO new{name=fuel-core}:initialize_loop{service="TxPool"}: fuel_core_services::service: 289: The service TxPool is shut down
2024-06-27T11:34:18.196719Z  INFO new{name=fuel-core}:initialize_loop{service="ConsensusParametersProviderTask"}: fuel_core_services::service: 289: The service ConsensusParametersProviderTask is shut down
2024-06-27T11:34:18.196767Z  INFO new{name=fuel-core}:initialize_loop{service="PoA"}: fuel_core_services::service: 289: The service PoA is shut down
2024-06-27T11:34:18.196930Z  INFO new{name=fuel-core}:initialize_loop{service="GraphQL"}: fuel_core_services::service: 289: The service GraphQL is shut down
2024-06-27T11:34:18.197013Z  INFO new{name=fuel-core}:initialize_loop{service="PoASyncTask"}: fuel_core_services::service: 289: The service PoASyncTask is shut down

Yes, I did change that too because as mentioned here, the owner address must be of B256 type address

1 Like