Break in code when trying to test contract

I’m following the instructions to build the counter smart contract and everything works fine till I run ‘cargo install cargo-generate’ which comes after compilation. This is what i get:

  • When i Run $ fuelup show i get this:
fuelup home: /root/.fuelup

installed toolchains
beta-3-x86_64-unknown-linux-gnu (default)

active toolchain
beta-3-x86_64-unknown-linux-gnu (default)
  forc : 0.37.3
    - forc-client
      - forc-deploy : 0.37.3
      - forc-run : 0.37.3
    - forc-doc : 0.37.3
    - forc-explore : 0.28.1
    - forc-fmt : 0.37.3
    - forc-index : 0.18.4
    - forc-lsp : 0.37.3
    - forc-tx : 0.37.3
    - forc-wallet : 0.2.2
  fuel-core : 0.17.11
  fuel-indexer : 0.18.4

fuels versions
forc : 0.39```

- Link to full scope of the codebase:
- I'm on a windows machine but i run my environment on the linux subsystem.

Hey @robberdom doesn’t seem like a Fuel issue but a dependency issue. Take a look at linux - How do I fix the Rust error "linker 'cc' not found" for Debian on Windows 10? - Stack Overflow

thanks, fren. i tried it and installed everything successfully. this is what i got still:

Updating index
error: binary `cargo` already exists in destination
Add --force to overwrite
error: there is nothing to install in `generate v1.5.0`, because it has no binaries
`cargo install` is only for installing programs, and can't be used with libraries.
To use a library crate, add it as a dependency to a Cargo project with `cargo add`.
     Summary Failed to install cargo, generate (see error(s) above).
error: some crates failed to install

Hey @robberdom still doesn’t look like a Fuel issue but looks like something wrong with your binaries. Have you tried the suggestion of forcing the overwrite?

no, i haven’t. how can i do that, please? @calldelegation

Hey @robberdom I was talking specifically within the error message you got.

error: binary `cargo` already exists in destination
Add --force to overwrite

After you have set up your environment properly you should be able to run

cargo install cargo-generate

Closing this for now as this is not a Fuel issue.