Can't deploy contract on fuel due to DNS/HTTP Error

root@DESKTOP-CGMNHPV:~# fuelup
Fuel Toolchain Manager

Usage: fuelup

check Check for updates to Fuel toolchains and fuelup
completions Generate shell completions
component Add or remove components from the currently active toolchain
default Set default toolchain
self Manage your fuelup installation
toolchain Install new toolchains or modify/query installed toolchains
show Show the active and installed toolchains, as well as the host and fuelup home
update Updates the distributable toolchains, if already installed
help Print this message or the help of the given subcommand(s)

-h, --help Print help
-V, --version Print version

Above is my fuel up command and it seems to be accurrate.

but when I use the forc deploy --testnet I keep getting: Error making HTTP request: error sending request for url ( error trying to connect: dns error: failed to lookup address information: Temporary failure in name resolution

DNS not found for on my side (ping check)

Hey @3nzyme and @Lecryptok, I’ve been unable to reproduce the issue you mentioned. Could you please try once more and let me know if you’re still encountering the problem?

It’s pretty much still the same error

1 Like

Sorry I ping with https://,
~ no issue when I run : ping

Hi @3nzyme, it seems like this issue might be unique to your setup, as no one else on my team has encountered it. Could you please run the following command and share the results with me? This will help us understand what’s happening. Thank you!