Don't see my node running

  1. I followed tutorial. Running this cmd on my remote VPS
fuel-core run \
--service-name={my_svc_name} \
--keypair {my_secret} \
--relayer {my_relayer} \
--ip=0.0.0.0 --port=4000 --peering-port=30333 \
--db-path=~/.fuel-sepolia-testnet \
--snapshot ./fuel/chain-configuration/ignition/ \
--utxo-validation --poa-instant false --enable-p2p \
--reserved-nodes /dns4/p2p-testnet.fuel.network/tcp/30333/p2p/16Uiu2HAmDxoChB7AheKNvCVpD4PHJwuDGn8rifMBEHmEynGHvHrf \
--sync-header-batch-size 100 \
--enable-relayer \
--relayer-v2-listening-contracts=0x01855B78C1f8868DE70e84507ec735983bf262dA \
--relayer-da-deploy-height=5827607 \
--relayer-log-page-size=500 \
--sync-block-stream-buffer-size 30

It started syncing the chain for a while. Then wanting the process to run in the background so trying a few running-background cmd and kill the ssh connection a few times. Eventually when I reconnect to my vps using the same cmd “fuel-core run…” above, got this result:

2024-06-28T19:14:57.943405Z  INFO fuel_core_bin::cli::run: 271: Block production disabled
2024-06-28T19:14:57.943441Z  WARN fuel_core_bin::cli::run: 296: The coinbase recipient `ContractId` is not set!
2024-06-28T19:14:57.943447Z  INFO fuel_core_bin::cli::run: 389: Fuel Core version v0.26.0
2024-06-28T19:14:57.943451Z  INFO fuel_core::combined_database: 94: Opening database "~/.fuel-sepolia-testnet" with cache size "1073741824"
2024-06-28T19:14:57.994542Z  INFO new{name=fuel-sepolia-testnet-node-kelvin}: fuel_core::service: 193: Initializing database
2024-06-28T19:14:57.994573Z  INFO new{name=fuel-sepolia-testnet-node-kelvin}: fuel_core::service: 197: Initializing sub services
2024-06-28T19:14:58.003366Z  INFO new{name=fuel-sepolia-testnet-node-kelvin}: fuel_core::graphql_api::api_service: 242: Binding GraphQL provider to 0.0.0.0:4000
2024-06-28T19:14:58.008471Z  INFO new{name=fuel-sepolia-testnet-node-kelvin}:initialize_loop{service="FuelService"}: fuel_core_services::service: 321: Starting FuelService service
2024-06-28T19:14:58.008642Z  INFO new{name=fuel-sepolia-testnet-node-kelvin}:initialize_loop{service="FuelService"}: fuel_core::service::genesis: 73: Genesis block created: V1(BlockHeaderV1 { application: ApplicationHeader { da_height: DaBlockHeight(5827607), consensus_parameters_version: 0, state_transition_bytecode_version: 0, generated: GeneratedApplicationFields { transactions_count: 0, message_receipt_count: 0, transactions_root: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855, message_outbox_root: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855, event_inbox_root: 0000000000000000000000000000000000000000000000000000000000000000 } }, consensus: ConsensusHeader { prev_root: 0000000000000000000000000000000000000000000000000000000000000000, height: 00000000, time: Tai64(4611686018427387914), generated: GeneratedConsensusFields { application_hash: 7cb9d322996c4efb45f92aa67a0cb351530bc320eb2db91758a8f4b23f8428c5 } }, metadata: Some(BlockHeaderMetadata { id: BlockId(dd87728ce9c2539af61d6c5326c234c5cb0722b14a8c059f5126ca2a8ca3b4e2) }) })
thread 'tokio-runtime-worker' panicked at crates/fuel-core/src/database.rs:195:9:
Height is already set for `on_chain`
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace
Aborted
  1. Result of running $ fuelup show
Default host: x86_64-unknown-linux-gnu
fuelup home: /root/.fuelup

installed toolchains
--------------------
latest-x86_64-unknown-linux-gnu (default)

active toolchain
----------------
latest-x86_64-unknown-linux-gnu (default)
  forc : 0.60.0
    - forc-client
      - forc-deploy : 0.60.0
      - forc-run : 0.60.0
    - forc-crypto : 0.60.0
    - forc-debug : 0.60.0
    - forc-doc : 0.60.0
    - forc-explore : 0.28.1
    - forc-fmt : 0.60.0
    - forc-lsp : 0.60.0
    - forc-tx : 0.60.0
    - forc-wallet : 0.7.1
  fuel-core : 0.26.0
  fuel-core-keygen : 0.26.0

fuels versions
--------------
forc : 0.62.0
forc-wallet : 0.62.0

3 - So the question is:
a. How to get the node up running?
b. How to get this process running in background properly? Tried to google, would be nice if you can list down details commands with expected response
c. How to test the result (by accessing from browser or any command from my local terminal)

2 Likes

Hi @KhaTruong123 ,

Can you try setting the ulimit on your system higher? And try again?

I’ll speak with the client team about the Height error, but the ulimit is something to try first.