Error on trying to set up fuel-core-keygen on VPS

leighg@fxnode3:~$ fuel-core-keygen new --key-type peering
component 'fuel-core-keygen' not found in currently active toolchain 'nightly-aarch64-unknown-linux-gnu'

- Run $ fuelup show and add the output below

Default host: aarch64-unknown-linux-gnu
fuelup home: /home/leighg/.fuelup

installed toolchains
nightly-aarch64-unknown-linux-gnu (default)

active toolchain
nightly-aarch64-unknown-linux-gnu (default)
  forc : 0.51.1+nightly.20240320.e40daf79b4
    - forc-client
      - forc-deploy : 0.51.1+nightly.20240320.e40daf79b4
      - forc-run : 0.51.1+nightly.20240320.e40daf79b4
    - forc-crypto : not found
    - forc-doc : 0.51.1+nightly.20240320.e40daf79b4
    - forc-explore : 0.28.1+nightly.20240320.4bb7392eed
    - forc-fmt : 0.51.1+nightly.20240320.e40daf79b4
    - forc-lsp : 0.51.1+nightly.20240320.e40daf79b4
    - forc-tx : not found
    - forc-wallet : 0.4.3+nightly.20240320.4d5fa8b121
  fuel-core : 0.23.0+nightly.20240320.8018aa0f21
  fuel-core-keygen : not found

- Detailed steps to recreate issue
I followed the guide to set up the testnet node along with the installation guide on a freshly set up version of Ubuntu 22.04. I am running this on an Oracle VPS with an arm64 cpu

- Link full scope of the codebase pertaining to your issue
Unsure that to link

- Any other relevant information

This worked when i logged in to another account on the vps via SSH but didnt work while using terminal over RDP

Hi @kwlg420

can you try the steps to update and setup your toolchain detailed on the solution here: Peering port error setting up node

you should try to use the beta-5 toolchain instead of the nightly version.

Nightly versions mybe unstable because they get frequently updated like everyday

1 Like