Error while Im trying to run my ndoe

I tried to run my own node, but after executing all commands in terminal, including " source $HOME/.cargo/env" and saving a chainConfig.json file im getting errors. The error retrived when i execute

fuel-core run
–service-name {ANY_SERVICE_NAME}
–keypair {P2P_SECRET}
–ip --port 4000 --peering-port 30333
–db-path ~/.fuel_beta5
–chain ./chainConfig.json
–utxo-validation --poa-instant false --enable-p2p
–min-gas-price 1 --max-block-size 18874368 --max-transmit-size 18874368
–reserved-nodes /dns4/,/dns4/
–sync-header-batch-size 100
–relayer-v2-listening-contracts 0x557c5cE22F877d975C2cB13D0a961a182d740fD5
–relayer-da-deploy-height 4867877
–relayer-log-page-size 2000

I replaced: any service (i removed {}) with node name, p2p_secret (removed {}) and ETH_RPC_ENDPOINTS with my alchemy api url (again, removed {}). The error is error: unexpected argument ‘’ found

Thank you for your help <3

Edit: It works now. I just forgot to add space between my eth endpoint url and /


Nice! Glad to hear it :slight_smile:

1 Like