Forc installation error

  • I tried to install forc using $ fuelup and got the error message below

  • Detailed steps to recreate issue
    I ran this command

curl --proto '=https' --tlsv1.2 -sSf \ | sh

to install forc using fuelup and when it yielded the error message of

sh: 1: cannot open html: No such file sh: 2: Syntax error: redirection unexpected

  • I removed the .sh | sh and added $ ./ to give this code instead

$ curl --proto '=https' --tlsv1.2 -sSf

  • It gave this result instead of a successful installation message


301 Moved Permanently

301 Moved Permanently

nginx `
  • Any other relevant information

I decided to open the link in the command ( ) and my PC gav me a warning that it is an insecure file.

Can you please tell me how to install forc using fuelup.

I use a Linux OS and Ubuntu is the distro.

1 Like

Hi Afoma! Could you try this newer command that’s in the quickstart?

curl | sh

Also, I’m curious where you found the deprecated command that you had tried?

1 Like

I think it’s from this course from the project.

Sway Lang and the Fuel Toolchain | LearnWeb3

( The course does a pretty good job explaining fuel’s unique architecture. It would be great if the course could be updated and the later sections completed . Hopefully they will get to it soon :slightly_smiling_face: )

1 Like

Thanks Sarah. I found it in the Web3rsvp course and this documentation as well

I feel so happy to see the amazing work that is being done here at Fuel. Great job!


Thanks so much :heart_hands:. It looks like that tutorial hasn’t been updated in a while :sweat_smile:, I’ll see if we can update it and add it to our main docs hub soon.

Also, that link to the Sway docs is for an out-of-date version. Is that linked in the web3rsvp tutorial too? Just to note, you can find the Sway docs for the current latest testnet here.

1 Like

Yes, it is linked to it.

Hello @sarah , so I followed the command in the new Fuel guide to install fuel-up and after installing, it gave this error message when it was supposed to download.

It says "curl: (22) The requested URL returned error: 404
fuelup: fuelup was not found - either the release is not ready yet or the tag is invalid. You can check if the release is available here:
When I opened that link in the command, it took me to 404 “Page not found” error page.

Interesting…would you mind also trying this command?

curl --proto ‘=https’ --tlsv1.2 -sSf | sh

I will, thanks, Sarah.