Stop working after few hours

I started the node but after a few hours it stops working. what could be the reason for this? In alchemy I see that I can repeat or the error with eth_getBlockByNumber. Inside nod see this WARN fuel_core_upgradable_executor::executor: 407: The block version(1) is different from the native executor version(0). The WASM executor will be used. is this the reason why he stop working?

HI @Patrycjusz ,

Thanks for this. Can you first provide the fuelup show results? Also, can you try restarting your node?

Default host: x86_64-unknown-linux-gnu
fuelup home: /root/.fuelup

installed toolchains

latest-x86_64-unknown-linux-gnu (default)

active toolchain

latest-x86_64-unknown-linux-gnu (default)
forc : 0.60.0
- forc-client
- forc-deploy : 0.60.0
- forc-run : 0.60.0
- forc-crypto : 0.60.0
- forc-debug : 0.60.0
- forc-doc : 0.60.0
- forc-explore : 0.28.1
- forc-fmt : 0.60.0
- forc-lsp : 0.60.0
- forc-tx : 0.60.0
- forc-wallet : 0.7.1
fuel-core : 0.26.0
fuel-core-keygen : 0.26.0

fuels versions

forc : 0.62.0
forc-wallet : 0.62.0

Restarting every they stop :slight_smile :slight_smile:

And? Whats next? What i do wrong?

Hi @Patrycjusz ,

We will investigate the issue. Can you provide the final fuel-core logs that you got before the node stopped?

First of all, I would suggest upgrading to fuel-core 0.30.0. The warning itself is not harmful. We need other logs(in most cases error logs) which will describe the problem.

how upgrading core?
Secon when nod stop see this information "The coinbase recipient “ConctractId” is not set!!

You can download new binary from release itself: Release v0.30.0 · FuelLabs/fuel-core · GitHub

Or build a new from sources by using Rust: cargo install fuel-core-bin --features production


try update but have this error

error: failed to compile fuel-core-bin v0.30.0, intermediate artifacts can be found at /tmp/cargo-install3pJxof.
To reuse those artifacts with a future compilation, set the environment variable CARGO_TARGET_DIR to that path.

its ok this isctrucion ? Or should use something diffrent?

the same error as above

@xgreenx Basically following official guide I also face with node stop syncing after few hours
you suggest to upgrade fuel-core but why don’t you put the proper version into your guide?

since cargo update doesn’t work I’ve tried to update from github binaries

tar -xvzf fuel-core-0.30.0-x86_64-unknown-linux-gnu.tar.gz
mv fuel-core-0.30.0-x86_64-unknown-linux-gnu/* /root/.fuelup/bin/

that’s what I did but fuelup show still says fuel-core is 0.26.0

fuel-core -V
fuel-core 0.30.0

And now work good or still stop after few hours?