How to upgrade fuel-core? Node Issue

Firstly, I am running my node with the script followed by the guide in docs.

I saw the newly released fuel-core version and trying the upgrade with following commands but it didn’t update the fuel-core:

fuelup self update
fuelup update
fuelup default latest

I restarted my node and I found warning as above screenshot showed.

How can I upgrade the fuel-core to get my node running normally? I can’t even use it in browser wallet(balance 0) since the beginning.

Appreciate for the help!

Hi, can you share your wallet config where you point to your local node, please? is your browser where your wallet is installed on the same machine where the node is running ?

What config specifically?
No, I am running the node in a cloud machine, different from my browser wallet installed.

Where your wallet is configured to connect to your node

as you might seen, the config likes that

1 Like

Most likely you just need to open your port. can you see if you get some html output if you run this on another ssh session

below my server is on my local lan from your server try and and your public server IP

devnode:~$ curl

<!DOCTYPE html>


  <meta charset=utf-8 />
  <meta name="viewport" content="user-scalable=no, initial-scale=1.0, minimum-

try also on the browser

for a bit of troubleshooting ,I also install net-tools

sudo apt install net-tools

then to see if there is a service running on port 4000 I do:

devnode:~$ sudo netstat -tunlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *               LISTEN      2934/fuel-core
tcp        0      0 *               LISTEN      561/systemd-resolve
tcp        0      0    *               LISTEN      772/sshd: /usr/sbin
tcp        0      0  *               LISTEN      2934/fuel-core
tcp        0      0 *               LISTEN      729/cupsd

On cloud servers you usually have router/firewall settings where you just need to open a port (depending on your provider ,sometimes you then need to go further and again open on the VMs that you spinoff )

For me its working and my balance shows with this config

let us know if you come right

Appreciate for your detailed steps.

I just followed all the steps you mentioned, but still 0 balance, I believe something wrong with my node, I will try restart and check again.

By the way, do you know how to update the fuel-core version to 0.28.0? I got the warn in the log:
fuel_core_upgradable_executor:: executor: 407: The block version (1) is different from the native executor version (0). The WAS executor will be used.
Does it matter?

Have a good day!