Command ‘Forc’ not found

forc new counter-contract

is giving me command forc not found.

This is like the fourth time I am running this code but I am getting the same error message

What can I do?

1 Like

Hey @mkolayiwola, were you able to go through the installation guide without any issues? Can you run fuelup show and post it here as well? :slight_smile:

Also you mean forc not ford right?


mike@Mkolayiwola:~$ fuelup show
Default host: x86_64-unknown-linux-gnu
fuelup home: /home/mike/.fuelup

installed toolchains

beta-4-x86_64-unknown-linux-gnu (default)

active toolchain

beta-4-x86_64-unknown-linux-gnu (default)
forc : 0.46.1
- forc-client
- forc-deploy : 0.46.1
- forc-run : 0.46.1
- forc-doc : 0.46.1
- forc-explore - not found
- forc-fmt : 0.46.1
- forc-index : 0.21.2
- forc-lsp : 0.46.1
- forc-tx : 0.46.1
- forc-wallet - not found
fuel-core : 0.20.5
fuel-core-keygen : Error getting version string
fuel-indexer - not found

fuels versions

forc : 0.45

Am I right on track?

Yes ‘forc’ not ‘ford’

Sorry typo error

Continue with the tutorial here. Can you post your error as well?

can you help me i have same problem

rachid@ph:~$ fuelup self update
Fetching binary from
Downloading component fuelup without verifying checksum
Unpacking and moving fuelup to /tmp/.tmpLgZzeE
Moving /tmp/.tmpLgZzeE/fuelup to /home/rachid/.fuelup/bin/fuelup
rachid@ph:~$ fuelup toolchain install beta-4

Downloading: forc forc-explore forc-index forc-wallet fuel-core fuel-core-keygen fuel-indexer

Adding component forc v0.46.1 to 'beta-4-x86_64-unknown-linux-gnu'
Installed forc v0.46.1 for toolchain 'beta-4-x86_64-unknown-linux-gnu'

Adding component forc-explore v0.28.1 to 'beta-4-x86_64-unknown-linux-gnu'
Installed forc-explore v0.28.1 for toolchain 'beta-4-x86_64-unknown-linux-gnu'

Adding component forc-index v0.23.0 to 'beta-4-x86_64-unknown-linux-gnu'
Installed forc-index v0.23.0 for toolchain 'beta-4-x86_64-unknown-linux-gnu'

Adding component forc-wallet v0.3.0 to 'beta-4-x86_64-unknown-linux-gnu'
Installed forc-wallet v0.3.0 for toolchain 'beta-4-x86_64-unknown-linux-gnu'

Adding component fuel-core v0.20.5 to 'beta-4-x86_64-unknown-linux-gnu'
Installed fuel-core v0.20.5 for toolchain 'beta-4-x86_64-unknown-linux-gnu'

Adding component fuel-core-keygen v0.20.5 to 'beta-4-x86_64-unknown-linux-gnu'
Installed fuel-core-keygen v0.20.5 for toolchain 'beta-4-x86_64-unknown-linux-gnu'

Adding component fuel-indexer v0.23.0 to 'beta-4-x86_64-unknown-linux-gnu'
Installed fuel-indexer v0.23.0 for toolchain 'beta-4-x86_64-unknown-linux-gnu'

- forc 0.46.1
- forc-explore 0.28.1
- forc-index 0.23.0
- forc-wallet 0.3.0
- fuel-core 0.20.5
- fuel-core-keygen 0.20.5
- fuel-indexer 0.23.0

The Fuel toolchain is installed and up to date
rachid@ph:~$ fuelup default beta-4
default toolchain set to 'beta-4-x86_64-unknown-linux-gnu'
rachid@ph:~$ mkdir fuel-project
mkdir: cannot create directory ‘fuel-project’: File exists
rachid@ph:~$ cd fuel-project
rachid@ph:~/fuel-project$ forc new counter-contract
component 'forc' not found in currently active toolchain 'beta-4-x86_64-unknown-linux-gnu'

this is the second time i try the first one i think it was bcs some of the installchain did not complete so i continued till this error show up, than I closed the terminal and opened again, and I start from here (see above)

here is the error that show up in the process of fuelup toolchain install beta-4

The Fuel toolchain is partially installed.
fuelup failed to install: - Could not add component forc(0.46.1): Failed to download forc-0.46.1-linux_amd64.tar.gz - response body closed before all bytes were read. The release may not be ready yet.
- Could not add component fuel-core(0.20.5): Failed to download fuel-core-0.20.5-x86_64-unknown-linux-gnu.tar.gz - response body closed before all bytes were read. The release may not be ready yet.

This is weird I will consult the tooling team and get back to you. :slight_smile: :palm_tree:

Hi there, @raxid !

Please check if if the PATH for that binary if properly set by typing.

$ which forc

Which should output something like this:


Then, try to navigate to that directory to check if the files were installed.

cd /home/myUserName/.fuelup/bin/forc

If you can’t access the .fuelup dir, there is likely to be an installation related issue.

If you can access to the forc binary, located in the bin directory of .fuelup, then the issue might be related to the “$PATH” variable in your terminal.

Please give it a try and let me know how it goes for you! :smiley: :palm_tree:

I followed the whole setup process and am getting the same error, as you see in the SS, forc is not found., I can’t initialize a new project. Please help.

You might need to manually install the binaries.

Check this guide.

This might be due to an issue on your local machine.