Fuel-core run Error

I encountered an error (a very silly one).
Here’s my code:
fuel-core run
–service-name ‘name’
–keypair ‘{“peer_id”:“”,“secret”:“”,“type”:“”}’
–relayer ‘https://eth-sepolia.g.alchemy.com/v2/hereKey
–ip --port 4000 --peering-port 30333
–db-path ~/.fuel_beta5
–chain ./chainConfig.json
–utxo-validation --poa-instant false --enable-p2p
–min-gas-price 1 --max-block-size 18874368 --max-transmit-size 18874368
–reserved-nodes /dns4/p2p-beta-5.fuel.network/tcp/30333/p2p/16Uiu2HAmSMqLSibvGCvg8EFLrpnmrXw1GZ2ADX3U2c9ttQSvFtZX,/dns4/p2p-beta-5.fuel.network/tcp/30334/p2p/16Uiu2HAmVUHZ3Yimoh4fBbFqAb3AC4QR1cyo8bUF4qyi8eiUjpVP
–sync-header-batch-size 100
–relayer-v2-listening-contracts 0x557c5cE22F877d975C2cB13D0a961a182d740fD5
–relayer-da-deploy-height 4867877
–relayer-log-page-size 2000

Error: No such file or directory (os error 2)

root@jigglypuff:/fuel# ls

I’m specifying incorrect paths to files, but I can’t figure out exactly which ones :(((
I’ve been using Windows all my life, so please don’t judge too harshly.

@Jigglypuff just to double check you are running this command from the same directory that you have your chainConfig.json file? Also the argument for --keypair should just be the secret and not the whole keypair

1 Like

Hi, sorry to reopen the thread again.

How do we check if we are running the command from the same directory as our chainConfig.json file?

Hi @Oxgene . Thanks for reaching out. :slightly_smiling_face:

basically you just run ls, you should see the chainConfig.json file


( on my setup I have fuel-core run command in that run_fuel.sh file so to start my node I do nohup ./run_fuel.sh & )

However that error you are getting Error: No such file or directory (os error 2) seems to be caused by running older packages and toolchain.

to update do:

fuelup self update
fuelup update
fuelup toolchain install beta-5
fuelup default beta-5

to confirm all went well you can run

fuelup show

You should see:

beta-5-x86_64-unknown-linux-gnu (default)

active toolchain

beta-5-x86_64-unknown-linux-gnu (default)
forc : 0.49.2
- forc-client
- forc-deploy : 0.49.2
- forc-run : 0.49.2
- forc-crypto : 0.49.2
- forc-doc : 0.49.2
- forc-explore : 0.28.1
- forc-fmt : 0.49.2
- forc-lsp : 0.49.2
- forc-tx : 0.49.2
- forc-wallet : 0.4.3
fuel-core : 0.22.1
fuel-core-keygen : 0.22.1

fuels versions

forc : 0.54.0
forc-wallet : 0.54.0

Hi crypto0mate, thank you for your swift reply.

i ran the updates, and also ran fuelup show. this is what i see.

root@vmi1752406:~# fuelup show
Default host: x86_64-unknown-linux-gnu
fuelup home: /root/.fuelup

installed toolchains

beta-5-x86_64-unknown-linux-gnu (default)

active toolchain

beta-5-x86_64-unknown-linux-gnu (default)
forc : 0.49.3
- forc-client
- forc-deploy : 0.49.3
- forc-run : 0.49.3
- forc-crypto : 0.49.3
- forc-doc : 0.49.3
- forc-explore : 0.28.1
- forc-fmt : 0.49.3
- forc-lsp : 0.49.3
- forc-tx : 0.49.3
- forc-wallet : 0.4.3
fuel-core : 0.22.1
fuel-core-keygen : 0.22.1

fuels versions

forc : 0.54.0
forc-wallet : 0.54.0

all of it seems to be the same except that i have .3 instead of .2? tried running the node again, and still getting the same error

let me know if there is anything i am still missing, thank you so much :slight_smile:

hmmmm :thinking: it could be your search path.

If you run echo $PATH do you see the fuel home /root/.fuel in your path

can you share the results of which fuel-core


I ran echo $PATH and got these results.

root@vmi1752406:~# echo $PATH

this is probably the issue right? :sweat_smile:

for which fuel-core, i get this

root@vmi1752406:~# which fuel-core

thanks again!

/root/.fuelup/bin appears several times in your path. you need to have unique directories.

one thing you can try is changing your command to use the full path like so

/root/.fuelup/bin/fuel-core run \ ......

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.