Is my node running correctly (beta4)

I did followed all steps on the guide to run node beta-4 not local one.
after the command

fuel-core run \
--service-name "LahcenKH" \
--keypair "..." \
--relayer "https://eth-sepolia.g.alchemy.com/v2/..." \
--ip 0.0.0.0 --port 4000 --peering_port 30333 \
--db-path  ~/.fuel_beta4 \
--chain ./chainConfig.json \
--utxo-validation --poa-instant false --network beta-4 --enable-p2p \
--min-gas-price 1 --max_block_size 18874368  --max_transmit_size 18874368 \
--bootstrap_nodes /dns4/p2p-beta-4.fuel.network/tcp/30333/p2p/16Uiu2HAm3xjsqASZ68KpaJPkPCMUiMgquhjyDHtxcVxVdFkMgRFf,/dns4/p2p-beta-4.fuel.network/tcp/30334/p2p/16Uiu2HAmJyoJ2HrtPRdBALMT8fs5Q25xVj57gZj5s6G6dzbHypoS \
--sync_max_get_header 100 --sync_max_get_txns 100 \
--relayer-v2-listening-contracts 0x03f2901Db5723639978deBed3aBA66d4EA03aF73 \
--relayer-da-finalization 4 \
--relayer-da-deploy-height 4111672 \
--relayer-log-page-size 2000

I got this screen

2024-01-28T12:06:41.202306Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170534..=5170534
2024-01-28T12:06:51.591988Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170535..=5170535
2024-01-28T12:07:02.047734Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170536..=5170536
2024-01-28T12:07:17.490666Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170537..=5170537
2024-01-28T12:07:27.865911Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170538..=5170538
2024-01-28T12:07:38.211768Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170539..=5170539
2024-01-28T12:07:53.733533Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170540..=5170540
2024-01-28T12:08:04.110441Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170541..=5170541
2024-01-28T12:08:19.473302Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170542..=5170542
2024-01-28T12:08:29.851944Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170543..=5170543
2024-01-28T12:08:50.272664Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170544..=5170544
2024-01-28T12:09:05.647561Z  INFO new{name=LahcenKH}:initialize_loop{service="Relayer"}: fuel_core_relayer::service::get_logs: 33: Downloading logs for block range: 5170545..=5170545

is it work fine? because after run in browser

http://MYIP:4000/graphql

not working

Hi @L-KH, everything looks good! Your local node is simply syncing at the moment.

A quick way to test if your GraphQL endpoint is functioning correctly is to visit http://127.0.0.1:4000/playground and run a query there. Let us know if you need any further assistance! :blush:

1 Like

I run on my vps. and I tried to check both

http://MYIP:4000/graphql
http://MYIP:4000/playground 

but weird that page doesn’t exist. seems like port not open or something, but its allowed.

You’re using the IP of --ip 0.0.0.0 can you try http://0.0.0.0:4000/playground?

sorry I still don’t get it. my command above was ip 0.0.0.0 --port 4000 , and I run on a vps, so that mean if I want to open in browser I should use my IP with port 4000, means http://vpsIP:4000/playground ? still not working it show no page

Ah, I understand now that you’re running the node remotely; I initially assumed it was a local setup. To troubleshoot the connection issue, I’d recommend checking a couple of things:

  1. Security Settings: Ensure that the security settings on your VPS allow inbound traffic on the necessary ports. This is a common area that might need tweaking.

  2. Local Firewall: It’s also possible that your local firewall is blocking connections specific to your VPS. A quick check of your firewall settings might reveal if this is the case.

From what I can see regarding your setup with Fuel, it looks like you’re doing everything correctly. These network-related checks are often the key in situations like this. Let me know how it goes!

thanks for your support. I did already check the firewall and ports, everything is open.
but if as you said everything is working fine. so maybe no need to check the graphql I think XD
btw here is the tuto followed: Running a Beta-4 Node | Fuel Docs
can’t see how to check logs

1 Like

can you help me please ,