(HELP) For Node Fuel Network

Hello, I’m opening this topic to get help on how to finish creating the node because I’m stuck and I’ve tried everything but without success, I’m a neophyte but I want to succeed with the node.

I followed the following FR tutorial: Ouvrir un node “Fuel Network”. Que ce soit pour participer à la… | by Ardanwen_SKT | Jan, 2024 | Medium

My error appears here :

fuel-core run
–service-name {ANY_SERVICE_NAME}
–keypair {P2P_SECRET}
–relayer {RPC_ENDPOINT}
–ip 0.0.0.0 --port 4000 --peering_port 30333
–db-path ~/.fuel_beta4
–chain ./chainConfig.json
–utxo-validation --poa-instant false --network beta-4 --enable-p2p
–min-gas-price 1 --max_block_size 18874368 --max_transmit_size 18874368
–bootstrap_nodes /dns4/p2p-beta-4.fuel.network/tcp/30333/p2p/16Uiu2HAm3xjsqASZ68KpaJPkPCMUiMgquhjyDHtxcVxVdFkMgRFf,/dns4/p2p-beta-4.fuel.network/tcp/30334/p2p/16Uiu2HAmJyoJ2HrtPRdBALMT8fs5Q25xVj57gZj5s6G6dzbHypoS
–sync_max_get_header 100 --sync_max_get_txns 100
–relayer-v2-listening-contracts 0x03f2901Db5723639978deBed3aBA66d4EA03aF73
–relayer-da-finalization 4
–relayer-da-deploy-height 4111672
–relayer-log-page-size 2000

Error :

"Error: an error occured while loading the chain config file./chainConfig.json

Caused by:
key must be a string at line 3 column 3"

I use MacOS.

Thanks

Hello @Psykotiick, I noticed you are using unofficial documentation. For the most accurate and current tutorials, I recommend checking out our official documentation here: Fuel Network Official Running a Beta 4 Guide.

Regarding your issue, did you successfully populate your chainConfig.json in the root directory ./ as mentioned in your command? The JSON file should resemble this example: Sample chainConfig.json.

If you encounter any further issues or have questions, please don’t hesitate to reach out. I’m here to help. :slight_smile:

2 Likes

Okay, thank you very much for your feedback! So I’ve started again: “Running a Beta-4 Node | Fuel Docs

Indeed, I’m stuck at the step (screen attached) because I don’t know how to open “chainConfig.json” and when I copy/paste the code in the black box nothing happens

Hmmm thats weird try this

{
  "chain_name": "Testnet Beta 4",
  "block_gas_limit": 30000000,
  "initial_state": {
    "coins": [
      {
        "owner": "0xa1184d77d0d08a064e03b2bd9f50863e88faddea4693a05ca1ee9b1732ea99b7",
        "amount": "0x1000000000000000",
        "asset_id": "0x0000000000000000000000000000000000000000000000000000000000000000"
      },
      {
        "owner": "0xb5566df884bee4e458151c2fe4082c8af38095cc442c61e0dc83a371d70d88fd",
        "amount": "0x1000000000000000",
        "asset_id": "0x0000000000000000000000000000000000000000000000000000000000000000"
      },
      {
        "owner": "0x9da7247e1d63d30d69f136f0f8654ee8340362c785b50f0a60513c7edbf5bb7c",
        "amount": "0x1000000000000000",
        "asset_id": "0x0000000000000000000000000000000000000000000000000000000000000000"
      },
      {
        "owner": "0x4b2ca966aad1a9d66994731db5138933cf61679107c3cde2a10d9594e47c084e",
        "amount": "0x1000000000000000",
        "asset_id": "0x0000000000000000000000000000000000000000000000000000000000000000"
      },
      {
        "owner": "0x26183fbe7375045250865947695dfc12500dcc43efb9102b4e8c4d3c20009dcb",
        "amount": "0x1000000000000000",
        "asset_id": "0x0000000000000000000000000000000000000000000000000000000000000000"
      },
      {
        "owner": "0x81f3a10b61828580d06cc4c7b0ed8f59b9fb618be856c55d33decd95489a1e23",
        "amount": "0x1000000000000000",
        "asset_id": "0x0000000000000000000000000000000000000000000000000000000000000000"
      },
      {
        "owner": "0x587aa0482482efea0234752d1ad9a9c438d1f34d2859b8bef2d56a432cb68e33",
        "amount": "0x1000000000000000",
        "asset_id": "0x0000000000000000000000000000000000000000000000000000000000000000"
      }
    ]
  },
  "transaction_parameters": {
    "contract_max_size": 16777216,
    "max_inputs": 255,
    "max_outputs": 255,
    "max_witnesses": 255,
    "max_gas_per_tx": 10000000,
    "max_script_length": 1048576,
    "max_script_data_length": 1048576,
    "max_storage_slots": 255,
    "max_predicate_length": 1048576,
    "max_predicate_data_length": 1048576,
    "max_gas_per_predicate": 10000000,
    "gas_price_factor": 92,
    "gas_per_byte": 4,
    "max_message_data_length": 1048576,
    "chain_id": 0
  },
  "gas_costs": {
    "add": 1,
    "addi": 1,
    "aloc": 1,
    "and": 1,
    "andi": 1,
    "bal": 13,
    "bhei": 1,
    "bhsh": 1,
    "burn": 132,
    "cb": 1,
    "cfei": 1,
    "cfsi": 1,
    "croo": 16,
    "div": 1,
    "divi": 1,
    "eck1": 951,
    "ecr1": 3000,
    "ed19": 3000,
    "eq": 1,
    "exp": 1,
    "expi": 1,
    "flag": 1,
    "gm": 1,
    "gt": 1,
    "gtf": 1,
    "ji": 1,
    "jmp": 1,
    "jne": 1,
    "jnei": 1,
    "jnzi": 1,
    "jmpf": 1,
    "jmpb": 1,
    "jnzf": 1,
    "jnzb": 1,
    "jnef": 1,
    "jneb": 1,
    "k256": 11,
    "lb": 1,
    "log": 9,
    "lt": 1,
    "lw": 1,
    "mcpi": 33,
    "mint": 135,
    "mlog": 1,
    "mod": 1,
    "modi": 1,
    "move": 1,
    "movi": 1,
    "mroo": 2,
    "mul": 1,
    "muli": 1,
    "mldv": 1,
    "noop": 1,
    "not": 1,
    "or": 1,
    "ori": 1,
    "ret_contract": 13,
    "rvrt_contract": 13,
    "s256": 2,
    "sb": 1,
    "scwq": 13,
    "sll": 1,
    "slli": 1,
    "srl": 1,
    "srli": 1,
    "srw": 12,
    "sub": 1,
    "subi": 1,
    "sw": 1,
    "sww": 43,
    "swwq": 44,
    "time": 1,
    "tr": 105,
    "tro": 60,
    "wdcm": 1,
    "wqcm": 1,
    "wdop": 1,
    "wqop": 1,
    "wdml": 1,
    "wqml": 1,
    "wddv": 1,
    "wqdv": 2,
    "wdmd": 3,
    "wqmd": 4,
    "wdam": 2,
    "wqam": 3,
    "wdmm": 3,
    "wqmm": 3,
    "xor": 1,
    "xori": 1,
    "call": {
      "base": 144,
      "dep_per_unit": 214
    },
    "ccp": {
      "base": 15,
      "dep_per_unit": 103
    },
    "csiz": {
      "base": 17,
      "dep_per_unit": 790
    },
    "ldc": {
      "base": 15,
      "dep_per_unit": 272
    },
    "logd": {
      "base": 26,
      "dep_per_unit": 64
    },
    "mcl": {
      "base": 1,
      "dep_per_unit": 3333
    },
    "mcli": {
      "base": 1,
      "dep_per_unit": 3333
    },
    "mcp": {
      "base": 1,
      "dep_per_unit": 2000
    },
    "meq": {
      "base": 1,
      "dep_per_unit": 2500
    },
    "retd_contract": {
      "base": 29,
      "dep_per_unit": 62
    },
    "smo": {
      "base": 209,
      "dep_per_unit": 55
    },
    "srwq": {
      "base": 47,
      "dep_per_unit": 5
    }
  },
  "consensus": {
    "PoA": {
      "signing_key": "f65d6448a273b531ee942c133bb91a6f904c7d7f3104cdaf6b9f7f50d3518871"
    }
  }
}

So I guess it opens the file, but how do I close it and continue?

Because when I was using the unofficial guide, it did the action and let me continue on the other one afterwards. I don’t know if you know what I mean (sorry, I’m a beginner and maybe I’m the problem lol).

I think I’ve found the solution to get to the next step, only here’s the new problem (never mind the secret key, I’ll redo the node).

Are you still having issues here @Psykotiick?

Yes… I struggle a little a lot :sweat_smile:

There is no clear step for running the node

What should I do next???

fuel-core-keygen new --key-type peering

Continue on, this is just a hint for what you need to do next.
Just run that command, save the output somewhere safe, you’ll need it later too, and move on.
then you create a file chainConfig.json, into which you copy what is in the article. Remember the location of the chainConfig.json file, you will need it later

1 Like

Yup thank you @Brave-Humens. Please let me know if you need anymore help @saadibeenco :slight_smile:

1 Like

Where can I find the status of my node? It is currently running, but I am unsure whether it is connected to Alchemy or the wallet. Additionally, how can I check the status of my node in the explorer? I would like to confirm whether my node is running or not.

If you’re operating the node on your local machine, kindly navigate to http://0.0.0.0:4000/playground. Once there, please execute a basic test GraphQL query to confirm that it’s functioning properly.

For example checking the base token balance of an address:


query {
  balance(owner:"0xb2c88b540df3660f782ddc45ff0a93c7a928af017251ec36d9b97ffe93257995", assetId: "0x0000000000000000000000000000000000000000000000000000000000000000") {
		amount
  }
}

See other examples here

What will be my owner and asset ID please?

The owner corresponds to any beta-4 fuel address, so you can use your own. The asset ID I have provided is the base asset ID, which is ETH.

You can also directly use the query I have provided.

So, listen pls understand I ran a node virtual server I used that Ip and my fuel wallet address, but response was not as expected.

Hello! Tell me please, you write here that “I” need to tie key to the node, but alas, I did not see this in the official guide. Tell me please how to add my wallet to the my installed node?

Hi @Brave-Humens, you don’t need to do that to run the testnet node. I would like to remind everyone that the current testnet is a non-incentivized network.

1 Like