"Socket Hang up" error while testing

When I’m trying to test my contract with ts-sdk, I get this error FetchError: request to failed, reason: socket hang up even though local fuel node is running


Hi @fsociety , are you still having this issue? Does a simple health query work for you?

1 Like

Hi @sarah! Yes, I’m still having this issue. I tried with both the latest and beta-2 versions but nothing changed

Thanks for letting me know. Can you share a repo and steps to reproduce this?

Hi @sarah! It’s a private repo but I can add you if you can share your GitHub id

1 Like

I’m running into the same issue when trying to run swayswap locally with the latest forc version. Did you manage to find a solution? @sarah @fsociety

Hi @dferrer! I was using the latest Node.js version which was 19.3.0 I believe. When I switched to the recommended version, 18.14.0, I never got that issue again


thank you, that solved the issue!

1 Like

Perfect! You’re welcome!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.