Can't install npm fuels - Cannot read properties of undefined (reading '_writableState')

hi guys, I tried to install fuels TS sdk package using npm but it didn’t work, also tried yarn but ended up with the same error.

npm ERR! node:internal/streams/writable:444
npm ERR! const state = stream._writableState;
npm ERR! ^
npm ERR!
npm ERR! TypeError: Cannot read properties of undefined (reading ‘_writableState’)
npm ERR! at _write (node:internal/streams/writable:444:24)
npm ERR! at Writable.write (node:internal/streams/writable:494:10)
npm ERR!
npm ERR! Node.js v20.10.0

Can anyone give me a solution, really appreciate your support!

1 Like

Is it possible for you to share your repo? I’m unable to reproduce this error with NodeJS v20.10.0 with a simple vite vanilla-ts repo.


Thanks for you reply, I haven’t started anything yet, just create empty folder and start install fuelsSDk using command “npm i fuels” and this error happened.

tried many times but it seems like I can’t install it

I believe you found a new bug:

1 Like

thank you, but any solutions for me? just tried it and continue failed

@Cku2411 have you tried this on WSL for Windows? For now, that would be the only way to make this work on Windows. We are working hard on a fix though, which should be out soon.


okie, finally installed it on WSL.
waiting for the Windows version, thanks