Error while installing `fuelup`

I am trying to install fuelup using the quickstart guide here. I can install Rust successfully but when I try to install fuelup using the command shown in the guide, it throws me this error

Can you please help me out with this


It is interesting, i can follow the guide and it installs correctly. Can you try again? Maybe it is about your connection.

I tried it multiple times, but it still shows me the same error. Also, I tried this on my friend’s machine, and it worked fine.

One difference I have noted it that when my friend tried to install it, it was downloading fuel 0.20.0 but on my machine, it is showing downloading fuel, maybe that’s the issue?

This is a very interesting bug and since it is somehow related to your local it is very hard to reproduce so sorry for the bombarding you with questions:

  1. Indeed the problem is your local cannot fetch the version while others can. fuelup fetches the version from the following url: can you try to manually open this or curl this url? If you cannot you probably have some sort of firewall setting stopping you to reach our repo on github.
  2. Maybe also try if you can reaching to our repo directly to see you can indeed view contents of the repo:
  3. Are you sure that you are not behind a weird proxy or something?
  4. Is your friend connected to the same network?
  5. Which operating system are you using?


hey! I couldn’t visit the URL unless I use a VPN. I even tried to switch my connection but didn’t work so ig it had something to do with my location. So I used a VPN and was able to install it correctly.
Thanks for helping me out.


Hey man. I have been facing a similar issue. If truly it is a VPN related matter, what country did you set your VPN to?

hey dude! I didn’t select intentionally but it was set to Germany.
Also, I encountered the same error you’re getting and I think it might be solved by deleting the ./.fuelup directory in the root and then running the command again. though, I am not sure that it will fix the error but at least that’s what worked for me.

Okay bro. Thanks for a response back. I got that resolved. Not by the VPN thing anyway. had to install NodeJS. Lol not a programmer. Now I face a new error after using

’ forc new counter-contract’ command

1 Like

Hey @buchii9 did you also install the beta-4 toolchain? Can you run fuelup show for me?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.