Node Peers issue and Wallet's RPC usage

Hello, I have a few questions

  1. I’m running a fuel node on testnet. The block is matching with new explorer ~274xxxx
    The issue is when it’s running fine for a few hours. I came back and see it only says
Downloading logs for block range 6127714..=6127742

Which is not current block and it won’t get back to normal syncing. I have to restart the service to get it back to sync current blocks.
I would like to know how to optimize this? using flags ‘–enable-mdns’ would help? or how can I add persistent peers to run command?

  1. I try add my node’s RPC (ip:port/v1/graphql) to fuel wallet extension on chrome. I can see my balance is correct and match with default RPC. But I couldn’t send any amount of tokens to another wallet address. It says success but it sent to void. The tx I got back was
https://fuellabs.github.io/block-explorer-v2/beta-4/#/transaction/0xc77a9ac66bd84a4854a158923a90dda6ef62f9c5a27b3553bbfbbfa0f4e4a381

which is not even a correct explorer and there’s no gas fee option before send too.

Thank you for your reply in advance,
Puckapao

Hey @puckapao this is weird I appreciate you bringing this up to my attention. I am testing this on my machine and will report back soon. :saluting_face:

1 Like


me like this.
it seems normal as it keeps downloading, but when I added the rpc to browser wallet, it doesnt work at all, 0 balance.
need someone to tell if it is working good or not.

Same issue with me. You can restart and it will back to work normally.

The issue still happen to me once a day like this morning but now still operating like normal for 9 hours now.

I have had the same error and I have solved it by modifying SystemD (assuming you use this service for the node).

Restart=on-failure
RestartSec=5s
StartLimitBurst=3
StartLimitIntervalSec=10s
TimeoutStartSec=60s
TimeoutStopSec=60s
LimitNOFILE=65535
WatchdogSec=60s
ExecStartPre=/bin/sleep 10

[Install]
WantedBy=multi-user.target

1 Like

Thank you I’ve updated my service with those settings and will give it a try.

1 Like


It looks like it’s restarting every 1 minute without any error. Do you know why? or do you have any additional flags set in ‘fuel-core run’ to help with this?

I leave you the complete systemD file, you only have to change it:
–keypair
–relayer https://eth-sepolia.g.alchemy.com/v2/ \

for your data…

In my case, since I modified the systemD, I haven’t had to restart the node and it works perfectly.


[Unit]

Description=Fuel Node Beta-5

After=network.target

[Service]

User=$USER

Type=simple

ExecStart=$(which fuel-core run) \

–service-name cumulofuel-sepolia-testnet \

–keypair \

–relayer https://eth-sepolia.g.alchemy.com/v2/ \

–ip=0.0.0.0 --port=5000 --peering-port=40444 \

–db-path $HOME/.fuel-sepolia-testnet \

–snapshot $HOME/.fuel-sepolia-testnet \

–utxo-validation --poa-instant false --enable-p2p \

–reserved-nodes /dns4/p2p-testnet.fuel.network/tcp/30333/p2p/16Uiu2HAmDxoChB7AheKNvCVpD4PHJwuDGn8rifMBEHmEynGHvHrf \

–sync-header-batch-size 100 \

–enable-relayer \

–relayer-v2-listening-contracts=0x01855B78C1f8868DE70e84507ec735983bf262dA \

–relayer-da-deploy-height=5827607 \

–relayer-log-page-size=500 \

–sync-block-stream-buffer-size 30

Restart=on-failure

RestartSec=5s

StartLimitBurst=3

StartLimitIntervalSec=10

TimeoutStartSec=60s

TimeoutStopSec=60s

LimitNOFILE=65535

WatchdogSec=60s

ExecStartPre=/bin/sleep 10

[Install]

WantedBy=multi-user.target

EOF

2 Likes

I have the exact same setup as yours because I’ve followed your guide on medium
I have now adjusted WatchdogSec to 3600s (1hr). It seems like Watchdog made the node restart too often (10s-60s)

1 Like

The value of WatchdogSec=60s ensures that systemd actively monitors the status of the service and restarts it if it does not respond within the specified time interval… if it is constantly restarting perhaps you should look at the capacity of your server and see if it is lacking resources.

That’s not the case for me though. My rack has 32c/64t and 256gb of RAM.
Watchdog force fuel node to restart itself without any error. After I set it to 3600s, it’s better now.

1 Like

hey great mate I will try that configuration although in my case I haven’t seen any node restarts, thanks for your feedback

1 Like