Local Fuel Explorer Failed startup after recent code updates

Hi Guys,

After the recent code updates, trying to create a local Fuel Explorer fails as the query to the testnet.fuel.network/v1/graphql fails as there is a recursion check.

Reproducing

  • Have all requirements installed
  • run ‘pnpm install’

The installation will fail with a GraphQL related error. Before the code update, I could run my own local Explorer.

I tried setting all “FUEL_PROVIDER” variables to a local copy of the schema. This partially worked but when running “pnpm dev”, the command failed again with another GraphQL related error.

Thanks

Hey @blackgrease, I tried running the command and it was working fine for me Warp
Can you share what repo are you cloning, to make sure we are on the same page? Also, can you share the output for the command fuelup show?

Hey @Nazeeh21 .

I am cloning this repo : GitHub - FuelLabs/fuel-explorer
and followed the instructions in the README for deploying locally. Before 8th July it worked well without any issues.

The ouput for ‘fuelup show’ is :

Yes, on the 9th we released a new version of fuel-vore v0.31.0 and with that, we introduced some breaking changes. I am sorry that it broke things for you. You can find the announcement here. Can you try updating the toolchain and retry?

So after updating (it said everything was up-to-date) I removed the repo and cloned it again. Running “pnpm install” succeded without any errors.

However, I seem to be using an old version of fuel core.

How can I use the recent version? 0.31

Can you please share the output for the command fuelup show?

Here is the output of fuelup show

This is the output of trying to install fresh version using the bash command:

Here is some more output if helpful.
image

This seems to be outdated. I’d suggest you proceed with the new installation

You can have a look at my output here. You might need to update your toolchain

Alright my output now seems to match yours and so far far I have not received the previous error concerning versions. Thank you.

Just another question as I am part of the Immunefi Fuel Attackathon, the nightly version is the most recent fuel core that fixes many Graphql issues right?

1 Like

It is the latest version but it does fix a lot of issues, not in particular about the GraphQL but overall in general. Also, we have not come across any issue with the GraphQL API reported by anyone

There was this changelog released : fuel-core/CHANGELOG.md at 2faae02d57be88d271893c822c781f34e5f445bc · FuelLabs/fuel-core · GitHub

Specifically at the end issue 1676

Does it apply to the Local running node? Or is the Graphql codebase different?

Sorry , Im trying to understand the environment.

I think a better question is:
Is the Graphql api in testnet.fuel.network different from the one used in the Local running explorer?

Are you referring to these?
image

I don’t think so those are different

Yes, this what im referring to. I see they arent present in the GraphL API running locally (Explorer) but reaching out to testnet.fuel.networks Graphql API does have these security controls.

Which is why im trying to understand if the GraphQL codebase is different for the setups.